Object reference not set to an instance of an object.

Sep 15, 2011 at 10:22 AM

Nice job guys, but if webapp configured as host-named site collections we have exception! http://technet.microsoft.com/en-us/library/cc424952.aspx

So really we do config on webapp url name for example  https://sharepointwebapp.fabricam.com/, but accesing with https://sharepointsitecollection.fabricam.com/ 

Exception below: (doesn`t mater Brayn or Orbit wsp is deployed! Exception is same.)

Event code: 3005

Event message: An unhandled exception has occurred.

Event time: 2011.09.15 12:31:08

Event time (UTC): 2011.09.15 09:31:08

Event ID: c5f652f6aa4c44b1aa7234e680fa2f24

Event sequence: 4

Event occurrence: 1

Event detail code: 0

 

Application information:

Application domain: /LM/W3SVC/1634663360/ROOT-1-129605526635704390

Trust level: WSS_Minimal

Application Virtual Path: /

Application Path: C:\inetpub\wwwroot\wss\VirtualDirectories\443\

Machine name: WW2

 

Process information:

Process ID: 7776

Process name: w3wp.exe

Account name: FABRICAM\sp.content.app.pool

 

Exception information:

Exception type: NullReferenceException

Exception message: Object reference not set to an instance of an object.

 

Request information:

Request URL: https://sharepointsitecollection.fabricam.com:443/_login/autosignin.aspx?ReturnUrl=An unhandled exception has occurred.f_layoutsAn unhandled exception has occurred.fAuthenticate.aspx2011.09.15 12:31:08fSource2011.09.15 12:31:08d%252F&Source=%2F

Request path: /_login/autosignin.aspx

User host address: 192.168.77.42

User:

Is authenticated: False

Authentication Type:

Thread account name: FABRICAM\sp.content.app.pool

 

Thread information:

Thread ID: 10

Thread account name: FABRICAM\sp.content.app.pool

Is impersonating: False

Stack trace: at BryanPorter.Claims.SignIn.Pages.AutoSignIn.Page_Load(Object sender, EventArgs e)

at System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e)

at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e)

at System.Web.UI.Control.OnLoad(EventArgs e)

at Microsoft.SharePoint.WebControls.UnsecuredLayoutsPageBase.OnLoad(EventArgs e)

at Microsoft.SharePoint.IdentityModel.Pages.IdentityModelSignInPageBase.OnLoad(EventArgs e)

at BryanPorter.Claims.SignIn.Pages.AutoSignIn.OnLoad(EventArgs e)

at System.Web.UI.Control.LoadRecursive()

at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

 

 

Custom event details:

Apr 17, 2013 at 9:43 AM
Edited Apr 17, 2013 at 9:44 AM
Hi msdnatealt,

Do you know if this issue was fixed?
I'm running into the same issue at the moment.
Apr 18, 2013 at 7:58 PM
I was able to fix this issue on my side.
At first I registered the assembly from the /Framework/ directory instead of the /Framework64/