first time install

Jul 29, 2010 at 6:15 PM

Hi I am trying to install this for the first time.

First I tried to package and deploy the source code but it did not work.

Now I am just trying to activate the solution that is provided here.

I uploaded it to the Solution Gallery.  Next I clicked the Activeate button and immediately received the following error message:

 

This solution contains invalid markup or elements that cannot be deployed as part of a sandboxed solution. Solution manifest for solution '8f2cdf22-f28f-4404-90c5-cd824bd790c5' failed validation, file manifest.xml, line 6, character 4: The element 'Solution' in namespace 'http://schemas.microsoft.com/sharepoint/' has invalid child element 'TemplateFiles' in namespace 'http://schemas.microsoft.com/sharepoint/'. List of possible elements expected: 'FeatureManifests, ActivationDependencies' in namespace 'http://schemas.microsoft.com/sharepoint/'.

Can you help me out?

John

 

Jul 29, 2010 at 8:18 PM

well, I retracted and deleted the solution.

Then I ran the first time deploy steps as provided on the Documentation tab.

Now I get the error below when I first navigate to the site:

 

Object reference not set to an instance of an object.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
Jul 29, 2010 at 9:37 PM
so, now I am debugging and SPContext is null. Nothing happens after that.
Jul 29, 2010 at 10:30 PM
Edited Jul 29, 2010 at 10:31 PM

omg i got it to work by adding the following as line #1:

SPWeb site = SPControl.GetContextWeb(Context);

and i set up the *MANDATORY* ip config info...

Now I get to play!

J